GB/T 35299-2026Information technology - Open systems interconnection - Object identifier resolution system (English PDF)
信息技术 开放系统互连 对象标识符解析系统
This is a limited preview
Buy now to download the full PDF (35 pages)
Need quotation for your management?
Get a formal quotation for GB/T 35299-2026 in 30 minutes.
Issued by
State Administration for Market Regulation
Level / Type
National · Recommended
Issue date
July 2, 2026
Implementation date
February 1, 2027
Scope
GB/T 35299-2026 is the English-translated version of 信息技术 开放系统互连 对象标识符解析系统.
GB/T 35299-2026 — This document specifies the requirements for object identifier resolution systems, mainly including. a) System composition and overall architecture of the object identifier resolution system; b) DNS-based resolution mechanism and inserting various application definition information related to OID nodes into the DNS zone file. method; c) Operational requirements for the object identifier resolution system client; d) Requirements of the object identifier resolution system service specification.
This document applies to the development, operation, and maintenance of object identifier resolution systems. The contents of the following documents, through normative references within the text, constitute essential provisions of this document.
Dated citations are not included. For references to documents, only the version corresponding to that date applies to this document; for undated references, the latest version (including all amendments) applies.
This document.
GB/T 13000-2025 Universal Coded Character Set for Information Technology (UCS) (ISO/IEC 10646:2020, MOD) GB/T 16263.4-2025 Information Technology ASN.1 Encoding Rules Part 4: XML Encoding Rules (XER) (ISO/IEC 8825-4:2021, IDT) GB/T 17969.1-2015 Operating Procedures of the OSI Registry for Open Systems Interconnection (OSI) – Part 1: General Procedures the top-level arc of the process and international object identifier tree (ISO/IEC 9834-1:2008, NEQ) GB/T 35300-2017 Information Technology Open Systems Interconnection - Procedures for Operating Organizations of Object Identifier Resolution Systems GB/T 46797-2025 Framework for resolving heterogeneous identifiers and locators based on object identifiers (OIDs) (ITU-T X.675.
2015, MOD) system(DDDS)-PartTwo.Thealgorithm] IETF RFC 3404 Dynamic Delegation Discovery Systems (DDDS) Part 4: Uniform Resource Identifiers applications (IDNA)
Found what you need?
Document preview — GB/T 35299-2026
National Standard of the People's Republic of China
- ICS
- 35.100.01
- Classification
- L 79
- Replacing
- GB/T 35299-2017
Issued by: State Administration for Market Regulation
Contents
- Preface
- 1 Scope
- 2 Normative References
- 3 Terms and Definitions
- 4 Abbreviations 5.
- 5 ORS Overview 6.
- 6 DNS zone files within the oid-res.org domain
- 7 ORS Client Operations
- Appendix A (Informative) Contact Information for the National Operator of oid-res.org
- Appendix B (Normative) ORS Service Type
- Appendix C (Normative) COIDORS Service Specifications
- Appendix D (Normative) CINFORS Service Specifications
- Appendix E (Normative) RINFORS Service Specification
- Appendix F (Normative) MINFORS Service Specification
- Appendix G (Normative) METADATAORS Service Specification
- Appendix H (Normative) OINFORS Service Specification
- Appendix I (Informative) Usage Instructions for Various Service Types
- Appendix J (Informative) ORS Operation Example
- Appendix K (Normative) Requirements for Domain Name Usage in Domestic OID Resolution Services
- Appendix L (Informative) Implementation Guidelines for ORS Area Local Cache and Replicas
- Appendix M (Informative) Operational Guidelines for ORS Operators
- References
Foreword
This document complies with the provisions of GB/T 1.1-2020 "Standardization Work Guidelines Part 1: Structure and Drafting Rules of Standardization Documents".
Drafting.
This document supersedes GB/T 35299-2017 "Information Technology - Open Systems Interconnection - Object Identifier Resolution System".
Compared with GB/T 35299-2017, apart from structural adjustments and editorial changes, the main technical changes are as follows.
definition;
b) Changed the requirement for OID node owners to manage their own ORS-supported DNS zones (see 6.1.4, version 2017);
c) Added the requirement that any OID node whose parent OID node does not support ORS implement ORS (see 6.1.11);
d) Added requirements for ORS secondary root servers (see 6.1.12);
e) Added requirements for authorization within DNS zones supported by ORS (see 6.2.5);
f) Added requirements related to improving ORS local performance (see 7.6);
g) The URI and the ORS service type of IDregistry have been changed (see Table B.1, Table B.1 in the 2017 edition).
This document is modified to adopt ISO/IEC 29168-1:2023 "Information technology - Open systems interconnection - Part 1: Object identifier resolution".
system".
This document has undergone the following structural adjustments compared to ISO/IEC 29168-1:2023.
a) The original standard Appendix A is changed to Appendix B of this document;
b) The original standard Appendix B is changed to Appendix C of this document;
c) The original standard Appendix C is changed to Appendix D of this document;
d) The original standard Appendix D is changed to Appendix E of this document;
e) The original standard appendix E is changed to appendix F of this document;
f) The original standard appendix F is changed to appendix I of this document;
g) The original standard appendix G is changed to appendix J of this document;
h) Change the original standard Appendix H to Appendix L of this document;
i) Change the original standard Appendix I to Appendix M of this document.
a) There are technical differences between 6.1 and ISO/IEC 29168-1:2023 6.1, in order to enhance the operation of oid-res.org in my country.
support.
b) Regarding normative references, this document has made adjustments to reflect technical differences to adapt to my country's technical conditions. Specific adjustments are detailed below.
as follows.
1) GB/T 17969.1-2015 has replaced ITU-T X.660(2011)|ISO/IEC 9834-1:2012 (see E.2.5);
2) GB/T 35300-2017 has been added as a reference (see 5.1.4);
3) References to IETF RFC 3401, IETF RFC 3402, and IETF RFC 3404 (see 6.3.2.3) have been added to enhance the understanding of...
NAPTR Technical Specifications;
6.3.1.3 of 29168-1.2023 adds a reference to GB/T 13000-2025 to adapt to the use of my country's coded character set.
Require.
c) The operating entity of "oid-res.org" shall be limited to the operating entity of oid-res.org in my country, and the oid-res.org domains under the jurisdiction of my country shall be specified.
The domains 156.2.1.oid-res.org and 156.16.2.oid-res.org and their subdomains are designated to strengthen the management of domestic OID nodes (see 5.1.2).
(and 6.1.2).
d) Replace all DNAME resource records in ISO/IEC 29168-1:2023 with both DNAME and CNAME resource records.
Records are provided to support various forms of OID resolution (see 6.3.1).
e) The usage method of NAPTR resource records with authorization expressions for variable information content has been changed (see 6.3.2.3) to enable the use of NAPTR records without modifying the authorization expression.
Under the premise of existing DNS zone files and application services, implement NAPTR for OID query requests and DNS wildcard mapping names.
Automatic conversion of resource records improves DNS efficiency and offers better compatibility and scalability.
f) The description of the interface protocol between the ORS client and other entities has been changed (see 7.1) to clarify the specific functional interface protocol.
Formula processing.
h) Add METADATA and OINFORS service types to Table B.1 in Appendix B (see Appendix B) to adapt to my country's...
Practical application of OID.
i) Appendix G (Normative) "METADATAORS Service Specification" has been added.
j) Appendix H (Normative) "OINFORS Service Specification" has been added.
k) An appendix K (normative) "Requirements for the Use of Domain Names for Domestic OID Resolution Services" has been added.
l) Annexes J and K of ISO/IEC 29168-1:2023 have been deleted.
The following editorial changes have been made to this document.
a) Rename the file to "Information Technology Open System Interconnection Object Identifier and Other Resolution System";
b) Section 5.1 was added to enhance the reader's understanding of the Object Identifier Resolution System (ORS);
c) Section 5.2 has been added to enhance the reader's understanding of the Object Identifier Resolution System (ORS);
d) Section 6.3.2.2 has been added to enhance the reader's understanding of DNS mapping names;
e) Added Appendix A (Informative) "Contact Information for National oid-res.org Operating Organizations";
f) Added sections I.5 and I.6 to Appendix I.
Please note that some content in this document may involve patents. The issuing organization of this document assumes no responsibility for identifying patents.
This document was proposed and is under the jurisdiction of the National Information Technology Standardization Technical Committee (SAC/TC28).
1 Scope
This document specifies the requirements for object identifier resolution systems, mainly including.
a) System composition and overall architecture of the object identifier resolution system;
b) DNS-based resolution mechanism and inserting various application definition information related to OID nodes into the DNS zone file.
method;
c) Operational requirements for the object identifier resolution system client;
d) Requirements of the object identifier resolution system service specification.
This document applies to the development, operation, and maintenance of object identifier resolution systems.
The contents of the following documents, through normative references within the text, constitute essential provisions of this document. Dated citations are not included.
For references to documents, only the version corresponding to that date applies to this document; for undated references, the latest version (including all amendments) applies.
This document.
GB/T 13000-2025 Universal Coded Character Set for Information Technology (UCS) (ISO/IEC 10646:2020, MOD) GB/T 16263.4-2025 Information Technology ASN.1 Encoding Rules Part 4: XML Encoding Rules (XER) (ISO/IEC 8825-4:2021, IDT) GB/T 17969.1-2015 Operating Procedures of the OSI Registry for Open Systems Interconnection (OSI) – Part 1: General Procedures the top-level arc of the process and international object identifier tree (ISO/IEC 9834-1:2008, NEQ) GB/T 35300-2017 Information Technology Open Systems Interconnection - Procedures for Operating Organizations of Object Identifier Resolution Systems GB/T 46797-2025 Framework for resolving heterogeneous identifiers and locators based on object identifiers (OIDs) (ITU-T X.675.
2015, MOD)
system(DDDS)-PartTwo.Thealgorithm] IETF RFC 3404 Dynamic Delegation Discovery Systems (DDDS) Part 4: Uniform Resource Identifiers applications (IDNA)
......
This preview omits tables, figures, formulas and parts of the technical clauses. The complete document — 35 pages — is available in the English PDF.
Referenced standards
Cited by
- GB/T 47266-2026Meteorological digital object identifiers - General
- GB/T 46067-2025Citywide digital transformation — General requirements for object identification system of city entity
- GB/T 46797-2025OID-based resolution framework for heterogeneous identifiers and locators
- GB/T 44873-2024Product traceability—Rules and requirements for traceability coding
- GB/T 44879-2024Identification requirements of engineering machinery products based on OID
- GB/T 40649-2021Intelligent manufacturing—Application guideline for identification resolution system of manufacturing object
How to Download GB/T 35299-2026
- 1
Add to cart
Click "Download PDF" on this page and choose "Buy this standard". You can add more standards before checkout.
- 2
Checkout
Enter your email and billing details. Payment is processed securely by Stripe (cards or bank transfer). Prefer bank details? Request a quotation (min. order $300).
- 3
Instant delivery (0–9 sec)
Delivery is automatic: within seconds of payment you'll receive an email with a secure download link. The link stays valid for 72 hours.
- 4
Invoice included
A tax invoice is attached to the confirmation email. Need a custom invoice? Contact us.
Related Standards
GB/T 10003-2026 — Biaxially oriented polypropylene (BOPP) film
GB/T 10004-2026 — Plastic/Plastic laminated films and pouches for packaging
GB/T 10007-2026 — Rigid cellular plastics - Determination of shear properties
Secure payment via Stripe
Payments accepted
GB/T 35299-2026
$500.00