GB/T 37075-2018Electronic product code—Information services (English PDF)
物品电子编码 信息服务
This is a limited preview
Buy now to download the full PDF (141 pages)
Need quotation for your management?
Get a formal quotation for GB/T 37075-2018 in 30 minutes.
Issued by
SAMR; SAC
Level / Type
National · Recommended
Issue date
December 28, 2018
Implementation date
July 1, 2019
Scope
GB/T 37075-2018 is the English-translated version of 物品电子编码 信息服务.
GB/T 37075-2018 is the Chinese national standard for the Electronic Product Code Information Services (EPCIS), prepared from the GS1 EPCIS version 1.1 specification without technical changes.
It defines how applications create and share visibility event data on physical or digital objects between and within enterprises. It specifies the abstract data model layer with event and master data and vocabularies, the data definition layer with the core event types, and the service layer interfaces for capture and query operations.
It also gives the XML definitions of the data modules and the bindings of the capture interface to message queues and HTTP and of the query interface to SOAP/HTTP, AS2 and callbacks, with extensive annexes including the XML schemas. It was issued on 28 December 2018 and has applied since 1 July 2019.
Found what you need?
Document preview — GB/T 37075-2018
National Standard of the People's Republic of China
- ICS
- 35.040
- Classification
- A 24
Issued by: State Administration for Market Regulation; Standardization Administration of the PRC
Contents
- Foreword
- Introduction
- 1 Scope
- 2 Normative references
- 3 Terms and Definitions
- 4 Abbreviations
- 5 EPCIS standard framework
- 5.1 Overview of the EPCIS Standard
- 5.2 Hierarchical structure of the EPCIS standard
- 5.3 Extension mechanism of the EPCIS standard
- 6 abstract data model layer
- 6.1 Event data and master data
- 6.2 Type of vocabulary
- 6.3 Extension mechanism
- 6.4 identifier representation
- 6.5 Grading Vocabulary
- 7 data definition layer
- 7.1 General rules for defining data definition layer modules
- 7.2 Core Event Type Module Overview
- 7.3 Basic components of the core event type model
- 7.4 Event 16 of the Core Event Type Module
- 8 Service Layer Interface Technical Requirements
- 8.1 Service Layer Interface Technical Overview
- 8.2 Core Acquisition Operation Module
- 8.3 Core Query Operation Module
- 9 XML definition of the data definition module
- 9.1 Scalable Mechanism
- 9.2 Standard Business Document Title
- 9.3 EPCglobal Infrastructure
- 9.4 Location Field Additional Information
- 9.5 Core Event Type Architecture
- 9.6 Master Data Architecture
- 10 core acquisition operation module binding
- 10.1 Overview of Binding of Core Acquisition Operation Modules
- 10.2 Message Queue Binding
- 10.3 HTTP Binding
- 11 Core Query Operation Module Binding
- 11.1 All bindings of the core query operation module
- 11.2 XML Schema of the Core Query Operations Module
- 11.3 Querying the SOAP/HTTP Binding of the Control Interface
- 11.4 Querying the AS2 Binding of the Control Interface
- 11.5 Querying the Callback Interface Binding
- Appendix A (informative) Relationship between EPCIS and GS1 system architecture
- Appendix B (informative) Principles and modular features of the EPCIS standard
- Appendix C (informative) Supplementary description of the abstract data model layer
- Appendix D (Normative) UML Form Class Diagram Representation
- Appendix E (Normative Appendix) Semantics of Data Definition Layer Events
- Appendix F (informative appendix) Quantity event
- Appendix G (informative) Supplementary description of the basic component modules of the core event type model
- Appendix H (informative) Supplementary notes to the events of the core event type module
- Appendix I (Normative) Method, parameters and fields for the service layer interface
- Appendix J (Normative) XML Binding for Data Definition Modules
- Appendix K (informative) XML example of core event data and master data
- Appendix L (Normative) The XML Schema of the Core Query Operations Module
- Appendix M (informative) GS1AS2 Guide
- Reference
Foreword
This standard was drafted in accordance with the rules given in GB/T 1.1-2009.
This standard refers to the International Article Numbering Association (GS1) "Article Electronic Code Information Service Specification Version 1.1" [EPCInformation Services (EPCIS) Version 1.1Specification] compiled.
Introduction
There is no change in the technical content of this standard and the Electronic Code Information Service (EPCIS) version 1.1 of the article. The goal of EPCIS is to make different Use programs to create and share visibility event data between the enterprise and the enterprise. The ultimate goal of this sharing is to make the user relevant. A shared view of physical or digital objects in a business environment.
In the relevant standards of EPCIS, "Object" generally refers to the physical reality identified by the class level identifier or the item level identifier. Body, and these physical entities involve the actual operational steps of one or more organizations' overall business processes. These physical entities include trade items Project (entity products), logistics units, recyclable assets, fixed assets, physical documents, etc. "Object" can also refer to digital products, also by class level It is not identified by the logo or the item level identifier, and also involves similar business process steps as described above. These digital products include digital trade Easy projects (music downloads, e-books, etc.), electronic documents (electronic coupons, etc.). The "object" in this standard is used to refer to a physics An entity or digitized product, identified by a class-level identifier or a item-level identifier, is the subject of a business process. EPCIS Data consists of "visibility events", where each "visibility event" is a record of one or more objects completing a particular business process.
The original idea of the EPCIS standard was to strengthen the cooperation between trading partners by sharing the details of physical entities or digital products. Work. The name EPCIS reflects the efforts made in the initial stages of the development of electronic coding of goods. However, it should be noted that EPCIS Electronic code and RFID data carriers are not required, and even EPCIS version 1.1 does not require item-level identification (item electronics) The encoding was originally identified only for instance-level objects when it was designed). The EPCIS standard applies to the collection and sharing of visibility event data. Shape, the expression of the name EPC is only a historical existence.
EPCIS provides an open, standard interface that allows for seamless integration of well-defined services across and within the enterprise.
Standard interfaces defined in the EPCIS standard can use the defined set of service operations and related data standards to collect and query visibility Pieces of data, combined with security mechanisms to meet the needs of users. In most cases, this will involve one or more visibility event data. A permanent database, although no permanent database is required, the elements of the service method can be used for direct sharing between applications.
Regardless of the existence of a permanent database, the EPCIS standard specifies only standard shared data interfaces between applications. Sets visibility event data, also used for data access. It does not specify how the service works and how the database itself is implemented. In addition to regulations In addition to the data required for standard EPCIS acquisition operations, this standard does not define how EPCIS services acquire/calculate the required data. Interoperability requires a standardized interface, but the implementation of the interface allows for the implementation of technology and implementation standards between enterprises or entities competition.
1 Scope
This standard specifies the abstract data model layer, data definition layer, and service layer interface of the electronic coded information service of the item, and specifies the data. Define the XML syntax description of the module, core acquisition operation module, and query operation module.
This standard applies to the use of the EPCIS standard to enable different applications to create and share visibility between and within the enterprise. Data, which in turn enables users to obtain a common view of physical or digital objects in the relevant business environment.
2 Normative references
The following documents are indispensable for the application of this document. For dated references, only the dated version applies to this document. For undated references, the latest edition (including all amendments) applies to this document.
GB/T 12905 barcode terminology
GB/T 17295 International Trade Unit of Measure Code
ISO 8601 data element and exchange format information exchange date and time representation (Dataelementsandinterchange formats-Informationinterchange-Representationofdatesandtimes)
GS1 Core Business Vocabulary Version 1.2 [GS1CoreBusinessVocabulary(CBV), version1.2]
GS1 Article Electronic Coded Label Data Standard Version 1.9 (GS1EPCTagDataStandard, version 1.9)
GS1 article electronic coding information service version 1.0 (GS1EPCInformationServices, version1.0)
GS1 technical documentation EDIINTAS1 and AS2 transmission communication guide (GS1TechnicalDocumentEDIINTAS1and AS2TransportCommunicationsGuidelines, Issue1, February.2006)
RFC2246 Transport Layer Security Protocol (TheTLSProtocol, Version 1.0)
RFC2396 Uniform Resource Identifier (URI). Generic Syntax [UniformResourceIdentifiers(URI). GenericSyn- Tax]
RFC2616 Hypertext Transfer Protocol HTTP/1.1 (HypertextTransferProtocol-HTTP/1.1)
RFC2818 HTTP over TLS (HTTPOverTLS)
RFC3268 Advanced Encryption Standard (AES) Cipher Suite for Transport Layer Security (TLS) [AdvancedEncryption Standard (AES)CipersuitesforTransportLayerSecurity(TLS)]
RFC4130 MIME-based secure peer-to-peer service data exchange using HTTP, Applicability Statement 2 (AS2) [MIME- BasedSecurePeer-to-PeerBusinessDataInterchangeUsingHTTP, ApplicabilityStatement2(AS2)]
3 Terms and definitions
GB/T 12905, GB/T 17295 and GS1 Core Business Vocabulary Version 1.2 (CBV1.2) and the following terms and definitions apply Used in this document.
3.1 Electronic code of goods
An identification scheme that broadly identifies physical objects (such as traded goods, assets, and locations) through RFID tags and other means.
Note: Standardized EPC data consists of an EPC (or EPC identifier) and optional filter values, where EPC is used to uniquely identify one or a class For individual objects, the filter values are chosen when it is judged that EPC tags need to be read efficiently and efficiently.
......
This preview omits tables, figures, formulas and parts of the technical clauses. The complete document — 141 pages — is available in the English PDF.
Referenced standards
Normative references
ISO 8601 · RFC2246 · RFC2396 · RFC2616 · RFC2818 · RFC3268 · RFC4130
Similar standards
How to Download GB/T 37075-2018
- 1
Add to cart
Click "Download PDF" on this page and choose "Buy this standard". You can add more standards before checkout.
- 2
Checkout
Enter your email and billing details. Payment is processed securely by Stripe (cards or bank transfer). Prefer bank details? Request a quotation (min. order $300).
- 3
Instant delivery (0–9 sec)
Delivery is automatic: within seconds of payment you'll receive an email with a secure download link. The link stays valid for 72 hours.
- 4
Invoice included
A tax invoice is attached to the confirmation email. Need a custom invoice? Contact us.
Related Standards
GB/T 12905-2019 — Bar code terminology
GB/T 17295-2008 — Codes for units of measure used in international trade
GB/T 7251.4-2026 — Low-voltage switchgear and controlgear assemblies - Part 4: Particular requirements for assemblies for construction sites (ACS)
Secure payment via Stripe
Payments accepted
GB/T 37075-2018
$1,895.00