Valid

GB/T 34145-2017Specification of programming interface for Chinese speech synthesis internet service (English PDF)

中文语音合成互联网服务接口规范

Preview PDF

This is a limited preview

Buy now to download the full PDF (18 pages)

Need quotation for your management?

Get a formal quotation for GB/T 34145-2017 in 30 minutes.

Issued by

SAMR; SAC

Level / Type

National · Recommended

Issue date

July 31, 2017

Implementation date

February 1, 2018

Scope

GB/T 34145-2017 is the English-translated version of 中文语音合成互联网服务接口规范.

GB/T 34145-2017 is the Chinese standard "Specification of programming interface for Chinese speech synthesis internet service".

Its scope clause reads: This standard specifies the scope of Chinese speech synthesis service system to provide services in the Internet environment, input data, output data, Service interface, interface return value requirements.

This standard applies to Internet-based Chinese speech synthesis service system interface design, development and application. Its clauses include terms and definitions.

Found what you need?

Document preview — GB/T 34145-2017

National Standard of the People's Republic of China

ICS
35.080
Classification
L 77

Issued by: State Administration for Market Regulation; Standardization Administration of the PRC

Contents

  • Preface
  • 1 Scope
  • 2 Normative references
  • 3 Terms and definitions
  • 4 voice synthesis service system capabilities
  • 4.1 Overview
  • 4.2 basic functions
  • 4.3 extended functions
  • 5 Enter the data
  • 5.1 Synthetic text
  • 5.2 Synthesis parameters
  • 6 output data
  • 6.1 Audio Data Format Requirements
  • 6.2 Synthetic audio description information
  • 7 service interface
  • 7.1 Initialization Components
  • 7.2 Create Speech Synthesis Session
  • 7.3 Setting the speech synthesis session parameters
  • 7.4 Writing Syntax
  • 7.5 Pause speech synthesis session
  • 7.6 Restore Speech Synthesis Session
  • 7.7 Stopping Speech Synthesis
  • 7.8 Get synthesized audio
  • 7.9 Get Synthetic Audio Description
  • 7.10 End Speech Synthesis Session
  • 7.11 Inverse Initialization Components
  • 8 Interface Return Value Requirements
  • Appendix A (informative) Synthetic audio description information message example

1 Scope

This standard specifies the scope of Chinese speech synthesis service system to provide services in the Internet environment, input data, output data,

Service interface, interface return value requirements.

This standard applies to Internet-based Chinese speech synthesis service system interface design, development and application.

2 Normative references

The following documents for the application of this document is essential. For dated references, only the dated version applies to this article

Pieces. For undated references, the latest edition (including all amendments) applies to this document.

GB 13000 Information technology common multi-octet-coded character set (UCS) (GB 13000-2010, ISO /IEC 10646.2003,

IDT)

GB 18030 Information technology Chinese encoding character set

GB/T 21024-2007 Chinese speech synthesis system - General technical specifications

Pinyin Scheme (Adopted at the Fifth Plenary Session of the First National People's Congress of the People's Republic of China)

RFC2045 Multipurpose Internet Mail Extensions Part 1. Internet Message Body Formatting [Multipurpose InternetMail

Extensions (MIME) PartOne.FormatofInternetMessageBodies]

RFC2586 Multipurpose Internet Mail Extensions Content Type (TheAudio/L16MIMEcontenttype)

RFC5646 Language Tags (Tags for Identification Language)

SSML1.1 speech synthesis markup language [SpeechSynthesisMarkupLanguage (SSML) Version1.1]

Handbook of the International Phonetic Association. A

GuidetotheseofInternationalPhoneticAlphabet)

3 Terms and definitions

The following terms and definitions apply to this document.

3.1 Speech synthesis

The process of converting a given text into a corresponding voice.

3.2 Speech synthesis markup language speechsynthesismarkuplanguage; SSML

A rich, XML-based speech synthesis markup language, in order to provide a standard way to control language on different platforms

Sound synthesis pronunciation, volume, speed and so on.

3.3 Chinese speech synthesis markup language Chinesespeechsynthesismarkuplanguage; CSSML

A set of XML-based markup language for Chinese speech synthesis.

Note .CSSML can be used for resource sharing in Chinese speech synthesis, module swapping, and intermediate data formats in distributed applications, or for standalone

Enter the control.

......
This preview omits tables, figures, formulas and parts of the technical clauses. The complete document — 18 pages — is available in the English PDF.

Referenced standards

Similar standards

How to Download GB/T 34145-2017

  1. 1

    Add to cart

    Click "Download PDF" on this page and choose "Buy this standard". You can add more standards before checkout.

  2. 2

    Checkout

    Enter your email and billing details. Payment is processed securely by Stripe (cards or bank transfer). Prefer bank details? Request a quotation (min. order $300).

  3. 3

    Instant delivery (0–9 sec)

    Delivery is automatic: within seconds of payment you'll receive an email with a secure download link. The link stays valid for 72 hours.

  4. 4

    Invoice included

    A tax invoice is attached to the confirmation email. Need a custom invoice? Contact us.

Related Standards

English PDF
18 pages
Instant delivery (0–9 sec)
Invoice included
View Cart

Secure payment via Stripe

Payments accepted

VisaMastercardAmerican ExpressApple PayGoogle PayStripe

GB/T 34145-2017

$315.00